UTi / kidney infection

Discussion in 'Third Trimester' started by keepontrying, Feb 21, 2012.

  1. keepontrying

    keepontrying Well-Known Member

    Joined:
    Sep 8, 2011
    Messages:
    294
    Likes Received:
    0
    I have had 7 courses of antiboitics since finding out i was pregnant, all for UTI's. The sample sent for culture came back as the ecoli bacteria. Just wondered if anyone else is having teh same issue.

    3 weeks ago the infection travelled to my kidneys and i was in agony, another trip to maternity triage and another course of tablets. I take tehm religiously, every 6 hours even setting my alarm through the night.

    Last week at my midwife appointment my urine tested +1 for protein and i could hardly produce more than a dribble, told her i thought teh infection was still there and she sent me back up the hospital, midwife there tested urine and told me it was completely normal to have +1 protein in urine and small amounts produced because of pressure on the bladder.. sent me home telling me i didnt need to wait around to see the doctor. So here i am a weeks later back in teh midst of a full blown infection again - i know its there and my midwife appointment in about an hour is sure to confirm this.

    I almost feel like demanding they admit me and give me intravenous antibiotics so this can clear once and for all... surely constant infections can cause long term problems for my body let alone risk early labour etc??!!
     
  2. bute69

    bute69 Well-Known Member

    Joined:
    Sep 11, 2011
    Messages:
    285
    Likes Received:
    0
    It sounds horrendous. I would have thought that the Hospital would do somethong to clear it up once and for all. Hope your midwife sorts it today for you.
     
  3. keepontrying

    keepontrying Well-Known Member

    Joined:
    Sep 8, 2011
    Messages:
    294
    Likes Received:
    0
    midwife update! she was mortified! whilst i was waiting i had a wee look at the notes from being sent up to the hospiatl last week - the midwife i saw there lied!!! she said i confirmed no symptoms of UTI which is untrue, it even says on the triage form from my initial phonecall to them that i had siad teh infection felt like it was still present.

    Anyhow- she contacted the hospital who were far to busy to see me! she is now trying to get a consultant appointment brought forward and i have a gp appointment this evening. She said that under no circumstances can this be ignored and was very unhappy about the treatment i had received so far!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice