Spotting but no period, 15 days late

Discussion in 'Am I Pregnant?' started by Katieeleanor, Jul 27, 2016.

  1. Katieeleanor

    Katieeleanor New Member

    Joined:
    Jul 27, 2016
    Messages:
    2
    Likes Received:
    0
    Hello, this is my first post so apologies if I make any errors or faux pas.

    I am 15 days late for my period. I started spotting the weekend that it was due and that continued for about 9 days. It was mostly brown spotting. On Thursday and the following Saturday, I thought my flow had started (as in, bleeding reached my underwear and I needed a tampon) both mornings only for it to switch off and go back to light brown spotting by the afternoon. Brown spotting tapered off very gradually and has been mixed with EWCM. Some days I've had a lot (more than I typically get when I ovulate). I took an ovulation test as a precaution but it was negative. Today it has been EWCM mixed with school glue and a tiny bit of pink spotting.

    All home pregnancy tests have been negative. I'm waiting for blood pregnancy test results (am also getting tested for general fertility issues as I'd made a doctors appointment to discuss TTC before my period went AWOL). I occasionally have sharp pains in my breasts and feel nausea (although I often feel nauseous due to acid reflux issues). Have been tired and cranky - but that's hardly out of the ordinary.

    Just wanted to get any insights or thoughts from anyone who may have experienced similar issues. I've never missed a period since being off birth control pills. My cycle isn't super regular. I am usually around 25 days with 5-6 days of spotting before my period but last month I went 27 days and only one day of spotting which I put down to taking B6.
     
  2. Crazycatwoman

    Crazycatwoman Well-Known Member

    Joined:
    Sep 10, 2015
    Messages:
    3,028
    Likes Received:
    0
    Do you know when you ovulate ? Could you have ovulated later in your cycle, sometimes you can get Ewcm with blood after ovulation. You would get a negative opk as the surge had gone x
    I haven't been ovulating, my periods arnt really period as. I spot, with medium flow for maybe half a day by but more spotting.
    I do also in process of fertility, had all tests done, just waiting to see the consultant.
     
  3. Katieeleanor

    Katieeleanor New Member

    Joined:
    Jul 27, 2016
    Messages:
    2
    Likes Received:
    0
    I tested for ovulation using Clear Blue digital, I got flashing smilies but not the solid smiley. I figured I missed the peak. That combined with CM indicated that I ovulated around CD13-14. According to Ovia my average ovulation day is around CD15. I have only started temping halfway through this cycle so there is the chance that I didn't ovulate, I suppose. I don't think that this is due to late ovulation. Because I have not had a full period, I'm on day 38 of my cycle (which would make this 13 or so days longer than usual with a lot of random spotting, bleeding and CM changes)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice