Implantation bleeding?

Discussion in 'Am I Pregnant?' started by mulderitsme, Mar 24, 2016.

  1. mulderitsme

    mulderitsme Active Member

    Joined:
    Mar 23, 2016
    Messages:
    27
    Likes Received:
    0
    Today I started bleeding "3 days late" but it's very light, nothing like my period.

    I took a test yesterday afternoon which was negative & was going to try again this morning but when I awoke at 6am I wiped brown blood. And...TMI...a few dribbles here and there of light red blood when I pee & now pink on the toilet paper.

    Could I have ovulated late? As I just remembered I had a vial infection on the day I was due to ovulate.

    Think I'm clutching at straws. We weren't trying & I know realistically it'll be better to wait a few more month till our little girl is a bit older but after thinking I could be pregnant I'm really struggling to let it go. :'(


    *There's been no blood for almost 2 hours now which isn't like a period for me.

    *Fresh red blood, albeit not a lot but I'm going to accept it's just my period. :(
     
    #1 mulderitsme, Mar 24, 2016
    Last edited: Mar 24, 2016
  2. PeanutButter

    PeanutButter Well-Known Member

    Joined:
    Nov 23, 2015
    Messages:
    5,122
    Likes Received:
    34
    When are you testing again, in the morning?
     
  3. mulderitsme

    mulderitsme Active Member

    Joined:
    Mar 23, 2016
    Messages:
    27
    Likes Received:
    0
    I don't think I need to now I've had some fresh red blood. :(
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice