have i just lost my plug or had a show?

Discussion in 'Ask a Mum!' started by annem, Jan 15, 2008.

  1. annem

    annem Well-Known Member

    Joined:
    May 19, 2007
    Messages:
    1,760
    Likes Received:
    0
    hi, i just went to the toliet and a clear/white jelly blob just fell out of me. Just had a good look at it :oops: but no blood. Was this my plug?

    how soon after losing your plug or having a show did you go into labour? x
     
  2. trixipaws

    trixipaws Well-Known Member

    Joined:
    Oct 13, 2006
    Messages:
    13,599
    Likes Received:
    0
    i had a tiny bit of something like that around 48 hours before i gave birth. i had the bloody one about 6 hours before the birth i was already in labour

    good luck!
     
  3. MissSara

    MissSara Well-Known Member

    Joined:
    Oct 10, 2007
    Messages:
    3,318
    Likes Received:
    0
    oooooo good luck if it is xxx
     
  4. Kylie1007

    Kylie1007 Well-Known Member

    Joined:
    Mar 23, 2007
    Messages:
    3,700
    Likes Received:
    0
    I lost my plug for about 4 or 5 days before I had the baby - it wasn't bloody - just like egg white :oops:
     
  5. Squiglet

    Squiglet Well-Known Member

    Joined:
    May 29, 2007
    Messages:
    8,899
    Likes Received:
    0
    I started getting that around Wednesday last week... then on Saturday, the same substance comes out and it was deep dark brown with red in it...

    but it's quite possible that it's the beginning of your show :)
     
  6. annem

    annem Well-Known Member

    Joined:
    May 19, 2007
    Messages:
    1,760
    Likes Received:
    0
    :cheer: gives me some hope, she is coming soon!! got the midwife tomo so will ask her to have a look to see whats going on :D
     
  7. Kylie1007

    Kylie1007 Well-Known Member

    Joined:
    Mar 23, 2007
    Messages:
    3,700
    Likes Received:
    0
    I phoned my mw to ask if the amount of discharge was normal ... then I rang her back 2 hrs later in labour!
     
  8. Babylicious

    Babylicious Well-Known Member

    Joined:
    Jun 13, 2007
    Messages:
    12,973
    Likes Received:
    0
    I had the same but mine has a tiny bit of blood in it, next day I was in labour
     
  9. Redshoes

    Redshoes Well-Known Member

    Joined:
    Nov 6, 2006
    Messages:
    5,532
    Likes Received:
    0
    I lost mine, then waters went, then contractions, all straight after each other, so it was immediate for me. Hope LO's on their way for you soon :cheer: :hug: :cheer:
     
  10. trixiehunnybun

    trixiehunnybun Well-Known Member

    Joined:
    Jan 4, 2008
    Messages:
    133
    Likes Received:
    0
    Sounds as if LO will be here soon, my waters went then about 10 mins later i had slimely stuff coming out, was all over before i knew what was happening! good luck
     
  11. BeckyJ

    BeckyJ Well-Known Member

    Joined:
    Nov 21, 2007
    Messages:
    3,544
    Likes Received:
    0
    let us know how you get on - good luck x
     
  12. Gemma & Jake

    Gemma & Jake Well-Known Member

    Joined:
    Mar 5, 2006
    Messages:
    2,730
    Likes Received:
    0
    I had a show about a week after my due date but I still had to be induced when I was 12 days over due. Mine was clear and like jelly with a bit of blood in it.
     
  13. lo1982uk

    lo1982uk Member

    Joined:
    Jan 6, 2007
    Messages:
    24
    Likes Received:
    0
    I had bits of the plug coming out for about a week and a half, the day before I went into labour, I had a very watery pink show all day, rang the labour ward as wasnt sure if it was my waters but they advised just a show.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice