confused.

Discussion in 'Trying to Conceive' started by rachh, Jul 14, 2013.

  1. rachh

    rachh New Member

    Joined:
    Jul 14, 2013
    Messages:
    1
    Likes Received:
    0
    Hi guys, new to this, i had my implant out on the 26th june 2013, had sex a week before removal and a week after removal unprotected.. My periods whilst on the implant were everywere, i was bleeding when i had it removed but stopped, i still havent come on, and have been having the period pains but no bleeding, i would love to concieve, any replys woulf be grateful thanks x rach x
     
  2. T84

    T84 Well-Known Member

    Joined:
    Dec 28, 2012
    Messages:
    5,576
    Likes Received:
    0
    Maybe your still waiting on first cycle hon, can take a while for body to get back into it. If your worried I would ask doc tho x x
     
  3. vic30

    vic30 Well-Known Member

    Joined:
    Jun 11, 2013
    Messages:
    2,593
    Likes Received:
    0
    Hi and welcome!

    I'm sorry, I don't know anything about the implant but if you've had unprotected sex then you're in with a chance. Any idea at all when period should be due? Period pain without period is a good sign I think so I guess all you can do is test or wait then test!

    Sorry I can't be more help, but fingers crossed!

    xx
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice