Advice

Discussion in 'Trying to Conceive' started by T84, Jun 12, 2013.

  1. T84

    T84 Well-Known Member

    Joined:
    Dec 28, 2012
    Messages:
    5,576
    Likes Received:
    0
    So as some of you will know from my journal I have been spotting since Saturday which was cd 26 (roughly 9dpo) it started as red on wiping but not every time. Since then it has varies between red and brown and mostly from wiping (again not always) had cramping on sat but nothing since. Today I have ovary pain and literally minimal spotting on wiping sometimes. What do you guys think? X x
     
  2. Dee28

    Dee28 Well-Known Member

    Joined:
    Feb 25, 2013
    Messages:
    4,448
    Likes Received:
    0
    Have you tested? I do often spot for 4 days before AF shows up like you describe but 5 days is a long time so I'd test to see if its a prolonged implantation bleed of sorts? Xx
     
  3. xxcharliexx

    xxcharliexx Well-Known Member

    Joined:
    Sep 6, 2011
    Messages:
    2,425
    Likes Received:
    0
    Seems like a long time to spot. If I was you I would test, if it is implantation surely it would show on a test now. At least then you would have more of an idea. Must be so annoying for u! Xx
     
  4. T84

    T84 Well-Known Member

    Joined:
    Dec 28, 2012
    Messages:
    5,576
    Likes Received:
    0
    Yeah it has been a long time especially as it was red at the start, that's pretty unusual for me. Think I'm gonna see if af shows tomorrow and if not test fri. Thanks ladies x x
     
  5. naomip

    naomip Well-Known Member

    Joined:
    Oct 16, 2012
    Messages:
    1,956
    Likes Received:
    0
    Good luck! I hope it's implantation x
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice